
ME 24-688 Introduction to CAD/CAE Tools

Nedjelja 12
Modeliranje toplotnog opterećenja mašinskog

elementa konačnim elementima
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Postavka zadatka

Elementi za odvod toplote se uobičajeno koriste
kako bi se omogućila disipacija toplote koju
generišu elektronski uređaji. Element za odvod
toplote je izrađen od aluminijuma (toplotna
konduktivnost k=170 W/(m·K), specifična toplota
c=870 J/(kg·K), E=70 GPa, n=0.3, r=2800 kg/m3,
koeficijent toplotnog širenja a=22·10-6 1/0C).
Ventilacijom vazduha po svim površinama,
izuzev donje površine, elementa za odvod toplote
se pospješuje hlađenje uređaja čiji je ulazni
toplotni fluks q.
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Postavka zadatka

Vazduh u radnom prostoru elementa za odvod
toplote je temperature od T=28 0C sa
koeficijentom prenosa toplote h=30 W/(m2· 0C), .
Odrediti:

• Raspodjelu temperature pri stacionarnom stanju
ukoliko je početna temperature elementa za
odvod toplote T=28 0C, konstatni ulazni toplotni
fluks po donjoj površini q=1000 W/m2
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Postavka zadatka

• Raspodjelu temperature pri nestacionarnom
stanju ukoliko je ulazni toplotni fluks kvadratna
funkcija sa periodom t=90 s i minimalnom,
odnosno, maksimalnom veličinom q=(0÷ 1000)
W/m2. Početno stanje raspodjele temperature
odgovara raspodjeli dobijenoj u prethodnom
koraku. Promjenu rapodjele temerature pratiti
t=180 s.

• Raspodjelu toplotnih napona u stacionarnom
stanju.
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Postavka zadatka

Granični uslovi: Nepokretan oslonac po donjoj površini

Opterećenje: Toplotni fluks po donjoj površini
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Sve dimenzije su date u mm

Fiksna donja površina
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Postavka zadatka
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Toplotno opterećenje

Aktivirati program ANSYS i sačuvati prazan
projekat pod nazivom Toplota
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Toplotno opterećenje

Kreirati stacionarnu termalnu analizu (Steady
State Thermal) na shemi projekta (Project
Shematic)
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Toplotno opterećenje

Aktivirati modul Engineering Data (Engineering
Data->Edit) i dodati novi materijal Click here to
add new material
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Toplotno opterećenje

Promjeniti jedinice i unijeti karakteristiku novog
izotropnog materijala (Isotropic Thermal
Conductivity)
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Toplotno opterećenje

Izabrati opciju Project za povratak na shemu
projekta
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Toplotno opterećenje

Aktivirati modul Design Modeler (Geometry-
>New Geometry)
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Toplotno opterećenje

Podesiti dužinske jedinice (Units->Milimeter)
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Toplotno opterećenje

Učitavanje eksterno generisane geometrije (File-
>Import External Geometry File) *.sat format
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Toplotno opterećenje

Učitavanje eksterno generisane geometrije
okončati komandom Generate
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Toplotno opterećenje

Aktivirati modul Steady-State Thermal (Model-
>Edit)
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Toplotno opterećenje

Podesiti dužinske jedinice (Units->Meter)
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Toplotno opterećenje

Izabrati materijal Details of Part 1->Material-
>Assignment podesiti na Aluminijum
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Toplotno opterećenje

Dodati stavku Mesh->Insert->Sizing u stablo
projekta
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Toplotno opterećenje

Zadati veličinu konačnih elemenata Details of
Mesh->Sizing->Element Size na 5e-4 m
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Toplotno opterećenje

Generisati mrežu konačnih elemenata Mesh-
>Generate Mesh
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Toplotno opterećenje

Dodati toplotni fluks u model Steady-State
Thermal->Insert->Heat Flux
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Toplotno opterećenje

Podešavanje veličine toplotnog fluksa Details of
Heat Flux->Definition->Magnitude koji djeluje po
donjoj površini na 1000 W/m2

Studijski program Mašinstvo – Konstruisanje pomoću računara



ME 24-688 Introduction to CAD/CAE Tools

Toplotno opterećenje

Dodati konvektivni prenos toplote u model
Steady-State Thermal->Insert->Convection koji
djeluje na sve (29 površina), osim donje površine
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Toplotno opterećenje

Podešavanje koeficijenta prenosa toplote Details
of Convection->Definition->Film Coefficient na 30
W/(m2·0C)
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Toplotno opterećenje

Podešavanje temperature vazduha Details of
Convection->Definition->Ambient Temperature
na 28 0C
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Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Thermal->Temperature
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Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Thermal->Total Heat Flux
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Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Thermal->Directional Heat Flux
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Toplotno opterećenje

Podesiti Details of Directional Heat Flux-
>Definition->Orientation na Y Axis
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Toplotno opterećenje

Aktivirati izvršenje analize Solution->Solve
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Toplotno opterećenje

Raspodjela temperature u ravnotežnom stanju
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Toplotno opterećenje

Raspodjela toplotnog fluksa
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Toplotno opterećenje

Raspodjela toplotnog fluksa u pavcu normalnom
na donju površinu
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Toplotno opterećenje

Kreirati nestacionarnu termalnu analizu
(Transient Thermal) povlačenjem na Steady-
State Thermal->Solution stavku stacionarne
analize
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Toplotno opterećenje

Prethodni postupak omogućava potrebno
povezivanje stacionarne i netacionarne termalne
analize
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Toplotno opterećenje

Aktivirati modul Engineering Data (Engineering
Data->Edit) i dodati podatke o gustini i specifičnoj
toploti
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Toplotno opterećenje

Izabrati opciju Project za povratak na shemu
projekta
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Toplotno opterećenje

Aktivirati modul Multiple Systems (Transient
Thermal->Setup->Edit) i odgovoriti sa Yes kako
bi se učitali novounešeni podaci
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Toplotno opterećenje

Podesiti vrijeme trajanja analize nestacionarnog
prenosa toplote Details of Analysis Settings-
>Step Control->Step End Time na 180 s
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Toplotno opterećenje

Podesiti način izbora vremenskog koraka Details
of Analysis Settings->Step Control->Auto Time
Stepping na On
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Toplotno opterećenje

Izabrati tip koraka analize Details of Analysis
Settings->Step Control->Define By na Time

Studijski program Mašinstvo – Konstruisanje pomoću računara



ME 24-688 Introduction to CAD/CAE Tools

Toplotno opterećenje

Podesiti parametre vremenskog koraka analize
Details of Analysis Settings->Step Control->Initial
Time Step na 0.1 s

Studijski program Mašinstvo – Konstruisanje pomoću računara



ME 24-688 Introduction to CAD/CAE Tools

Toplotno opterećenje

Podesiti parametre vremenskog koraka analize
Details of Analysis Settings->Step Control-
>Minimum Time Step na 0.05 s
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Toplotno opterećenje

Podesiti parametre vremenskog koraka analize
Details of Analysis Settings->Step Control-
>Maximum Time Step na 5 s
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Toplotno opterećenje

Dovoljno mali vremenski korak povećava tačnost
analize i omogućava dovoljan broj koraka koji
rezultira simulacijom sa finim prelaskom sa
između koraka analize
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Toplotno opterećenje

Dodati toplotni fluks u model Transient Thermal-
>Insert->Heat Flux
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Toplotno opterećenje

Podešavanje veličine toplotnog fluksa Details of
Heat Flux->Definition->Magnitude koji djeluje po
donjoj površini na Tabular Data
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Toplotno opterećenje

Unijeti tabelarne podatke o toplotnom fluksu kao
na slici

Studijski program Mašinstvo – Konstruisanje pomoću računara

Klikne se u donje
lijevo polje i unese
vrijeme, a nakon
toga u desno donje
polje i unese fluks
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Toplotno opterećenje

Dodati konvektivni prenos toplote u model
Transient Thermal->Insert->Convection koji
djeluje na sve (29 površina), osim donje površine
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Toplotno opterećenje

Podešavanje koeficijenta prenosa toplote Details
of Convection->Definition->Film Coefficient na 30
W/(m2·0C)
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Toplotno opterećenje

Podešavanje temperature vazduha Details of
Convection->Definition->Ambient Temperature
na 28 0C
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Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Thermal->Temperature

Studijski program Mašinstvo – Konstruisanje pomoću računara



ME 24-688 Introduction to CAD/CAE Tools

Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Thermal->Total Heat Flux
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Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Thermal->Directional Heat Flux
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Toplotno opterećenje

Podesiti Details of Directional Heat Flux-
>Definition->Orientation na Y Axis
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Toplotno opterećenje

Aktivirati izvršenje analize Solution->Solve
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Toplotno opterećenje

Simulacija promjene raspodjele temperature
opcija Graph
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Toplotno opterećenje

Simulacija promjene raspodjele toplotnog fluksa
opcija Graph
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Toplotno opterećenje

Simulacija promjene raspodjele toplotnog fluksa
u smjeru Y ose opcija Graph
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Toplotno opterećenje

Kreirati strukturnu analizu (Static Structural)
povlačenjem na Steady-State Thermal->Solution
stavku stacionarne analize
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Toplotno opterećenje

Prethodni postupak omogućava potrebno
povezivanje stacionarne termalne analize i
strukturne analize
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Toplotno opterećenje

Aktivirati modul Engineering Data i dodati
podatke o gustini, modulu elastičnosti, Poisson-
ovom koeficijentu, koeficijentu toplotnog širenja
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Toplotno opterećenje

Izabrati opciju Project za povratak na shemu
projekta
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Toplotno opterećenje

Aktivirati modul Multiple Systems (Static
Structural->Setup->Edit) i odgovoriti sa Yes kako
bi se učitali novounešeni podaci
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Toplotno opterećenje

Dodati nepokretni oslonac na donju površinu
Static Structural->Insert->Fixed Support
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Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Stress->Equivalent von Mises
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Toplotno opterećenje

Izabrati analizu koja se želi realizovati Solution-
>Insert->Stress->Total Deformation
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Toplotno opterećenje

Aktivirati izvršenje analize Solution->Solve
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Toplotno opterećenje

Raspodjela toplotne deformacije
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Toplotno opterećenje

Raspodjela toplotnih von Mises-ovih napona
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